【Unity】エディタバージョンを変更すると「MonoBehaviourは見つかりませんでした」エラーが出る

Unity

現象

エディターのバージョンを最新版に変更したとき、画像のように赤い波線が大量に出た。

MonoBehaiourも見つからないらしい。

解決方法

どこでもよいので、新しいスクリプトファイルを作成して開くと、治ります。

どうせ消すので、名前は適当でファイルを作成。

ダブルクリックで開く

エラーが消えました。

ほかのファイルを見ても、先ほどの赤い波線は消えています。

この問題の原因はわかりませんが、この方法で対応可能です。

何だったんだ…

タイトルとURLをコピーしました